Author Topic: How to stop mipped textures in P3D V4.  (Read 521 times)

0 Members and 1 Guest are viewing this topic.

Offline Musician_89

  • Turbine Captain
  • *****
  • Posts: 547
How to stop mipped textures in P3D V4.
« on: February 12, 2019, 04:56:33 PM »
I'm having a bit of a headache with mipped texutres appearing on my AI. I've done everything, maxed out texture settings, graphics settings etc and still my aircraft is appearing blurry. The repaints look great upclose but it keeps happening and it's actually stresisng me out  ::fighting:: ::fighting:: the textures just don't look great at all.

When i install the texutres on AIFP it usually says "DDS-Mipped" surely mipped is a loss in quality? Is there a way i can change it so that I can always use the highest quality paint instead of the mipped version?

It's not every airline this is happening too e.g. the Norwegian paints look fantastic and no problems at all but Icelandair, Ryanair, BA e.t.c. it doesn't look that great.
« Last Edit: February 12, 2019, 05:10:29 PM by Musician_89 »
Please forgive if me i post something "stupid" I am autistic so certain things are harder for me.

Offline integral

  • Turbine 2nd Officer
  • ***
  • Posts: 223
Re: How to stop mipped textures in P3D V4.
« Reply #1 on: March 08, 2019, 01:42:08 PM »
Hi !
You have two options, none of them are easy :

1) Find the tool called DXTBmp (it's free, google-it). Locate all installed AI textures with the issue. Delete all mips from those textures and save them again in the appropriate format (if it's DDS, then it should remain DDS). Well, actually, the format isn't a problem, it's just to avoid doing something unexpected because you changed so many parameters that the saved texture deteriorates. What matters is you install 32bits textures and save in 32bits color depth aswell (no quality loss) after getting rid of all mips.

2) Or, buy another graphic card. But good luck having the brand and model that doesn't suffer the loss of detailed mip version. Problem is, your PC config isn't balanced (Motherboard+CPU+Graphic Card+RAM+Hard Drive), and it happens SOME graphic cards works well on a given system, and looses track of detailed textures (mips) on another. Why ? I really don't know, but I had that problem until I changed both the graphic card and the hard drive. It appeared the hard drive wasn't able to reload the most detailed version of the texture fast enough when the graphic card asked for it, so the aircraft (or scenery) remained blurred until you applied max zoom. However, the issue remained around some very detailed sceneries, and I had to upgrade RAM, then the problem disappeared.... then came back when I loaded PMDG. That's when I resorted to the option above and deleted ALL mips upon installing EACH SINGLE AI repaint. Though, that was FS9 and FSX. I havent upgraded to P3D yet, but since it's mostly an highly upgraded version of FSX, I believe the problem to be the same.
October 2015 : Are all animated parts in FSX require keyframes ? Are they the same keyframes as FS9 ? It appears they aren't.. X_X

Offline Dave YVRATC

  • Command Captain
  • *******
  • Posts: 1688
    • My Flickr photostream
Re: How to stop mipped textures in P3D V4.
« Reply #2 on: March 08, 2019, 04:58:34 PM »
 Mipped is far better for you system, sure you have some bluriness with distance but I see it as more realistic as aircraft at that distance aren't crisp to view in real life anyways (if they are really blurry or unreadable then its with your videocard or maybe videocard setting). Non mipped textures also shimmer and stand out like crazy, it would drive me nuts to see those shimmers again. Back in the early FSX days when lots of scenery and ai was non-mipped, every time I saw a shimmer, I had to fix it right then and there by adding mips. There's a reason why the sim itself as well as all addons have mipped textures, don't go backwards.  ;)

Offline jhaley101

  • AIG Dispatch Beta Tester
  • Command Captain
  • ***
  • Posts: 1927
Re: How to stop mipped textures in P3D V4.
« Reply #3 on: March 08, 2019, 06:38:50 PM »
I have to admit that I grimaced a bit when I read the subject of this post.   After all, we've spent a lot of space here discussing MIPS/texture sizing/  ;)

Agree completely with Dave on two important points he mentions. 

1)  Mipped is far better for your system.   Every single one of my AI textures is mipped (and by choice - resized) and I don't experience any blurry textures in my present P3D setup or when I started to pay more attention to the issue as a user of FSX. 

2) You're call with what you do with your own sim, but supporting Dave's position, you will be taking a step backwards in deleting, installing and resaving textures.  Besides the scope of the project (depending on how much AI you have) I'm still not a big fan of 32 bit textures, but that may be more of a paranoia from my FS9 days.   

Could you post a picture of what you are experiencing as far as blurry textures are concerned?   Perhaps the forum crowd can provide some input for suggestions on improving textures via settings.   

I'm truly interested to see what you see when you say the textures are blurry. 

Good luck
« Last Edit: March 08, 2019, 07:11:31 PM by jhaley101 »

Online jabloomf1230

  • Turbine 2nd Officer
  • ***
  • Posts: 145
Re: How to stop mipped textures in P3D V4.
« Reply #4 on: March 09, 2019, 11:04:29 PM »
This is best, recent, simple, non-technical discussion of textures and mipmaps that I have read:

https://beyondskyrim.org/ddstextures/

Mipmapping improves performance but it does not come without some a penalty. Mipmapped textures have both larger file sizes and use more video RAM. There is also a very small amount of overhead caused by the GPU deciding which mipmap size to use, but I don't think that the average flightsim user would ever see that small difference. In the "old days", video cards were limited as to their VRAM, so it was important to always use mipmapped texture sheets.

Given all that, there is no reason to replace all the mipmapped AI aircraft textures. On the other hand, having  some non-mipmapped AI aircraft textures won't have a noticeable impact on performance unless your GPU is more than 3 generations old.

Offline Dave YVRATC

  • Command Captain
  • *******
  • Posts: 1688
    • My Flickr photostream
Re: How to stop mipped textures in P3D V4.
« Reply #5 on: March 10, 2019, 07:49:27 AM »
  Either way, between the LOD's, lack of shimmering and the fact that all of the scenery developers including ACES and LM goingto mipping their textues well over a decade ago, I'll stick to the mips. They didn't do just for shits and giggles.

Offline jhaley101

  • AIG Dispatch Beta Tester
  • Command Captain
  • ***
  • Posts: 1927
Re: How to stop mipped textures in P3D V4.
« Reply #6 on: March 10, 2019, 10:42:26 AM »
Agreed.    From the story referenced by way of link:

"Unless your primary concern is file size, the benefits of mipmapping more than outweigh the costs."