Author Topic: [OPEN] No textures and no addition to aircraft.cfg  (Read 267 times)

0 Members and 1 Guest are viewing this topic.

Offline BruceN

  • Command Captain
  • *******
  • Posts: 1892
[OPEN] No textures and no addition to aircraft.cfg
« on: April 16, 2019, 11:48:57 PM »
First the good news..
0.8.5.4 fixed the unavailable menus I was experiencing with 0.8.5.3.   ::cheers::

Now the bad news..

I am still seeing approximately half of my installs not having textures nor updates to the aircraft.cfg.

As an example, I click the Online menu, then the Available Online menu. I select French Bee and then go with Install using OCI. The aircraft are properly set, and I click Install. The aircraft are already in the simobjects folder for this sample and the textures downloand. The flightplan compiles and the process ends. However I don't have textures in either of the aircraft folders and nothing added to the aircraft.cfg files.

All of this is after a clean install of 0.8.5.4 just to be sure nothing from 0.8.5.3 can interfere with the installation.

Logs attached indicating Object reference not set to an instance of an object when trying to install the textures.
« Last Edit: April 18, 2019, 04:38:21 AM by Kaiii3 »

Online Kaiii3

  • AIG Technic
  • Command Captain
  • *****
  • Posts: 2380
    • Kai's AFD Studio
Re: No textures and no addition to aircraft.cfg
« Reply #1 on: April 17, 2019, 04:36:50 AM »
noe we can say that this is something on your setup...

Code: [Select]
Model already installed: AIGAIM_FSP_A350-900
Unable to detect SimObject-Object/Check OCI.cfg

this shows me, that the folder "AIGAIM_FSP_A350-900" is present, but AIM can not find it after loading all cfg files... Can you upload the filehirachie incl. the filenames of the folder? I'm sure we will find the bug


AIG Software Developer

Offline sharklet_a319

  • AIG Dispatch
  • Command Captain
  • *****
  • Posts: 5239
Re: No textures and no addition to aircraft.cfg
« Reply #2 on: April 17, 2019, 08:53:18 AM »
Could be a mix up of freeware and payware A350 again - pls attache the oci.cfg file.
Regards, Chris

AIG Admin | AIG Beta | AIG Dispatch | AIG Tech | P3Dv4

Offline BruceN

  • Command Captain
  • *******
  • Posts: 1892
Re: No textures and no addition to aircraft.cfg
« Reply #3 on: April 17, 2019, 09:40:19 AM »
If this is a problem with locating the oci.cfg file, then that would explain why the same models fail to load the texture folder(s) and modify the aircraft.cfg files when other models are working properly. When I was installing a set of flightplans a couple of days ago, the B738 winglets folder never contained the textures when all other aircraft folders were fine. Deleting the aircraft in the simobjects folder, clearing the temporary files, and then restarting OCI fixed the problem. That forced a new set of aircraft folders and perhaps the new oci.cfg file allowed the textures to load?

As requested, the file hierarchy and oci.cfg file from the FSP A350 are attached.

When this aircraft was first installed by OCI, the FSPXAI_A350XWB_V2_for AItraffic_FSXP3D_Stage1.zip file was used to create the folder.

Online Kaiii3

  • AIG Technic
  • Command Captain
  • *****
  • Posts: 2380
    • Kai's AFD Studio
Re: No textures and no addition to aircraft.cfg
« Reply #4 on: April 18, 2019, 04:36:21 AM »
hvae you tried the reinstall approch you did with the 738 on the A350, because the folder seems to be correct and the oci.cfg is like mine ::confused::


AIG Software Developer

Offline BruceN

  • Command Captain
  • *******
  • Posts: 1892
Re: [OPEN] No textures and no addition to aircraft.cfg
« Reply #5 on: April 18, 2019, 03:17:43 PM »
My standard workaround is:
  • Delete the problematic aircraft folder
  • Remove the temporary installation files
  • Restart AIGAIM
  • Repeat cycle until I get a texture folder and updated aircraft.cfg
  • Remove duplicate [fltsim.x] entries from the retries in the other aircraft folders

I can confirm that once I have a working aircraft folder, I don't encounter the problem of missing textures and cfg changes with subsequent installs to that aircraft folder. It's the initial creation of the folder that is problematic. It's always the Object Reference errors in the log files. Flightplans can be removed, but the remaining textures and cfg entries has been happening since version 0.8.4.

Online Kaiii3

  • AIG Technic
  • Command Captain
  • *****
  • Posts: 2380
    • Kai's AFD Studio
Re: [OPEN] No textures and no addition to aircraft.cfg
« Reply #6 on: April 18, 2019, 03:24:02 PM »
the problem seems to be that AIM can not read the SimObject-Folder and then the later can not use it, eaven if its a valid directory... Can you send me a Log for a first time SimObject-Folder installation, maybe we can find something in there ::confused::


AIG Software Developer

Offline BruceN

  • Command Captain
  • *******
  • Posts: 1892
Re: [OPEN] No textures and no addition to aircraft.cfg
« Reply #7 on: Yesterday at 03:59:38 PM »
Still the same problems, and now a new one..

Several days ago I tried to install Sunwing and Sun Country. Using the method mentioned previously, I cleared all of the simobjects and cleared the temporary files. Restarted AIGAIM, tried to install the airlines and simobject folders created with oci.cfg and other files, but no textures and no additions to aircraft.cfg. Repeated this process again 5 times. No textures.

Completely removed AIGAIM, all associated folders everywhere, cleared the addons.cfg of the AIM entries, and cleaned the registry. Installed 0.8.5.4, added the configuration data, logged into the websites, then tried to install the 2 airlines. No textures and no additions to the aircraft.cfg files. I cleared the temp data, restarted AIGAIM, and no success. I then checked the security settings on all associated folders and files, and full control was enabled. There should be no problem with the file security and installing the files.

After restarting AIGAIM 4 times after the reinstall, I had texture folders appear and the aircraft.cfg files update. Nothing done differently except restarting the program over and over.

Today, I attempt to install Joy Air, Okay Airways, and update Aerologic. I try to install from downloaded zip files. The airline install window opens, but when I click the Install using OCI button, the installation window closes and I'm back to the AI Manager window. This happens with each of the 3 install files, so I then select the check online menu, and select Joy Air from the list. Click the install button and the window closes and I'm at the AI Manager window.

Log indicates :Unable to instal OCI Plan and also says Sequence contains more than one element.

See attached log.

I will wait for a suggestion what I should do next.


Online Kaiii3

  • AIG Technic
  • Command Captain
  • *****
  • Posts: 2380
    • Kai's AFD Studio
Re: [OPEN] No textures and no addition to aircraft.cfg
« Reply #8 on: Yesterday at 04:13:35 PM »
seems that you had multiple AIM Entries in your addon.cfg files ::confused:: Please start AIM and try again, and then send me the log again


AIG Software Developer

Offline BruceN

  • Command Captain
  • *******
  • Posts: 1892
Re: [OPEN] No textures and no addition to aircraft.cfg
« Reply #9 on: Yesterday at 04:57:30 PM »
I forgot that you requested a log for an initial install of 0.8.5.4.

I removed all files, configurations, and registry entries, then reinstalled. See attached log.


Regarding the previous error with the multiple entries, the attached log in the previous message was after restarting AIM the third time to confirm it was consistently happening.

Online Kaiii3

  • AIG Technic
  • Command Captain
  • *****
  • Posts: 2380
    • Kai's AFD Studio
Re: [OPEN] No textures and no addition to aircraft.cfg
« Reply #10 on: Yesterday at 05:53:52 PM »
so you you can setup OCI again and then everything should work without problems


AIG Software Developer