Author Topic: Cannot launch AIM  (Read 450 times)

0 Members and 1 Guest are viewing this topic.

Offline chasensfo

  • Turbine Captain
  • *****
  • Posts: 626
  • Ahoy there
Cannot launch AIM
« on: January 13, 2021, 11:53:36 AM »
Ahoy there guys,

Though I manually install all my AI as I have various traffic periods through history and thus I need to keep things organized(for example my "Delta" texture folder in the FAIB 767-300 has about 40 textures covering it's introduction to the airline to present), I decided to finally install AIM to access PBR capable models for FAIB and others that I can't get otherwise. Well, I ran into some major issues. As I have the 1950s thru present day in my sim with traffic split up into 2-year periods(though I only activate one period at a time in the scenery library), I have thousands and thousands of traffic.bgls in my sim. Loading AIM for the first time took 8 hours(!) with FREQUENT pop ups warning that I had "incorrect" airports for my sim set up. Seriously, there were so many pop-up warnings it was ridiculous. Well, obviously since I have retro traffic, airports like VHHX instead of VHHH and XDEN for Denver Stapleton instead of KDEN ect are all over my files from other years. So I had to sit there and close the pop-ups over, and over, and over again while I was on my PC that entire time of the scanning of my traffic files would hang. I figured I'd only have to do this the first time, right? Then after that I can just use the program. WRONG!

It loaded that first time, but of course my bloody internet went down after so I couldn't download any packages to get the models. Now since then, everytime I try to launch AIM, it wants to scan my thousands of traffic files, again, and the pop ups are back even though I already told the app not to worry about them. Is the info not located then stored in the app after that first giant half-day scan?

Well, obviously I am not going to take 8 hours to launch this program, but I want the models, so how do I get around this? Keep in mind we're making a RetroAI installer, so while right now my case is unique, hopefully in the next year or so there will be a lot of folks who have similar set ups with thousands of traffic.bgls in their sim(if they want every available era in their sim, anyway). So will having historic traffic make OCI not work, or is there a work around?

Thanks,
Chasen

Offline Jon

  • AIG Dispatch Beta Tester
  • Command Captain
  • ***
  • Posts: 3046
Re: Cannot launch AIM
« Reply #1 on: January 13, 2021, 12:12:28 PM »
Please attach the program Log files so the programmers can review.
To Err is Human, to Forgive is Divine. Neither of Which is SAC Policy.

A good plan violently executed right now is far better than a perfect plan executed next week.
George S. Patton

Offline chasensfo

  • Turbine Captain
  • *****
  • Posts: 626
  • Ahoy there
Re: Cannot launch AIM
« Reply #2 on: January 13, 2021, 12:23:49 PM »
OK I have done so. Ranmori has a similar set up and told me he thinks temporarily moving all traffic.bgls out of P3D and to a temporary folder for storage while using AIM is his work-around solution, and that worked. However, it did still take 15 minutes even with 0 traffic.bgls in my sim. I am wondering if this is because I have so many aircraft.cfg entries? I am just wondering if there is any solution to this issue other than having to cut\paste all the traffic files elsewhere everytime AIM is used. To me it is just tedious\annoying but not a big deal to take this extra step, but I'm just thinking about the future needs of less sim-saavy folks once they have a bunch of decades of traffic.bgls installed and of course will be using AIM for their modern stuff. I have learned that simply installing aircraft textures is a huge learning curve for a lot of folks so this may be a bit problematic. Didn't see this coming. LOL. Ugh.

Thanks for the quick reply!

Offline Jon

  • AIG Dispatch Beta Tester
  • Command Captain
  • ***
  • Posts: 3046
Re: Cannot launch AIM
« Reply #3 on: January 13, 2021, 12:39:37 PM »
Seems like a safe bet.  I have about half of the AIM content installed, MAIW MATRIX North American installed, and General aviation/government as manual install.  Takes AIM abut 6 minutes or so load.
To Err is Human, to Forgive is Divine. Neither of Which is SAC Policy.

A good plan violently executed right now is far better than a perfect plan executed next week.
George S. Patton

Offline chasensfo

  • Turbine Captain
  • *****
  • Posts: 626
  • Ahoy there
Re: Cannot launch AIM
« Reply #4 on: January 13, 2021, 10:29:01 PM »
Interesting, just to test it, I removed my AI aircraft to a different directory and it loaded in about 5 or 6 minutes like you said. Hmm OK, well I guess I can just do the work around for myself and we'll just have to let users know in the future that if they want to use AIM\OCI that they need to move their traffic.bgls temporarily to avoid huge loading delays. Thanks for the replies.

The pitfalls of "trail blazing" with all this retro traffic.  :)